Magento released a new version of Magento 2 yesterday. The Magento 2 preinstall on Hypernode has been updated to reflect this. The new preinstalled version when you order a Hypernode is 2.3.0.

Note that as of right now magerun2 is not yet compatible with this new version, so keep that in mind when you want to interact with the system. For more information about Magento 2.3 see this Dutch blogpost on byte.nl or the English version on hypernode.com.